Ribbon

From Tygron wiki
Jump to: navigation, search

After reading this page:

  • you've learned how the ribbon relates to the Tygron Platform.
  • you've learned the general layout of the ribbon .
  • you've learned what options are available through the ribbon header.


How does the ribbon relate to the Tygron Platform

The ribbon is located in the top part of the editor. It is a tabbed header, which provides access to tools grouped by categories. Those categories are in organized in tabs. This makes tools accessible in a logical way.

The editor. The Ribbon at the top of the screen, the Left Panel on the left side of the screen, the User Main Interface in the center of the screen, the Right Panel on the right side of the screen, and the Bottom Panel at the bottom of the screen.


Ribbon overview

Editor ribbon.jpg

The ribbon at the top consists of 2 parts, the ribbon header and the ribbon bar.

The ribbon header provides access to the File Menu and five other tabs:


Clicking on one of these five tabs reveals a menu on the ribbon bar corresponding to the selected tab.

The tab that is currently active is colored, while the non-active tabs are grey.

Ribbon bar dropdown menu

The ribbon bar dropdown menu

A dropdown menu can be presented when hovering buttons on the ribbon bar. The dropdown menu can be used as a shortcut to access the left panel, to add items to your project, or can redirect users to the documentation section.

Calculation Panel

The Calculation panel helps you to manage the calculation time of your project. The Calculation Panel can be found by hovering with your mouse over the 'A' circle-arrow button. Recalculate panel.JPG

Team Chat Box

The Team Chatbox allows communication between other users within your team. The Chatbox Channel menu can be used to switch in between channels

Team chatbox.jpg

Ribbon tab overview

This section shows a full overview of available tabs and buttons when using the ribbon.

File

Main article: File menu.
File Pane

Selecting the "File" Tab from the ribbon header opens the File Menu.

Current Situation

Main article: Current Situation.
Editor ribbon header currentsituation.jpg

The Current Situation tab contains functions and options related to base of the project. This means things like structures, neighborhoods, overlays and indicators can be viewed and edited. Data present in the current 3d world can be received with the TQL tool. Data can also be added with the Geo Import button.

Future Design

Main article: Future Design.
Editor ribbon header futuredesign.jpg

The Future Design tab contains options focused on the planning/scenario aspect. Actions and measures and events can be managed, and viewing perspective can be changed to the stakeholders that active in the project. The project functionalities can also be tested with the test run option

Multi Stakeholder

Main article: Multi Stakeholder.
Editor ribbon header multistakeholder.jpg

The Multi-Stakeholder tab contains the options to design a story for a multi-stakeholder analyses. This consists of managing stakeholders, designing story with levels, a timeline and messages and project explanation with intro tests and interface options.

Tools

Main article: Tools.
Editor ribbon header tools.jpg

The Tools tab contains miscellaneous tools which consists of view and recording options in particular.

Community

Main article: Community.
Editor ribbon header community.jpg

The Community tab contains the different aspects of our community hub. Here knowledge and assets on the different functionalities of the Platform can be acquired.